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Collaborative Project Management (CPM) 

CPM provides a collaborative platform for a team to simultaneously work on a project.  It 

guides the team through every step in the lifecycle of the project. 

  

Step 1: Project Initiation 

 You will go through a few simple steps to create a project.  A project composed of a 

number of tasks and sub-tasks to be completed within the project timeline.  A project is 

also a common workspace online for a team to share and coordinate their works and 

resources.  This section shows you how to create and publish project.   

Create a New Project 

To begin, you click the following link (available on the Home Page). 

Click to add a new project 

Clicking the above link will put you into the page to Create a New Project.  Fill 

out the Project Name and other information requested on this page.  If you don't 

know what Project Privacy to pick, choose Private.  You can change that later. 

Private Projects are only seen by project team members. 

Public Projects can be seen, comment on and upload files by all people of your 

company. 

Public Read-only Projects can be read by all people of your company, but only 

team-members can comment and upload files. 

Choose a Project Template 

Continue from above and click Next>> 

You will be asked to choose a project template from the Library.  Pick a type of 

project that is closest to the project you want to create.  If you or other people of 

your company had run a similar project in CPM, you would probably have a 

Project Plan Template saved from before that you can choose from, otherwise 

either picks one from the default templates or you have to create one of your own. 

Review the content in the Project Plan Layout window and feel free to modify the 

template plan to suit your need.  Click Next>> to review how the plan would look 

like, then click <<Prev to come back to the Template Layout to further your 

modification. 

Note that some of the templates already have timeline specified for each task.  

This is done by specifying the GAP and DURATION for each task.  And the 

format is by appending GAP and DURATION in Days at the end of the task 

name.  For example, 

Finalize wedding card design :: 2, 10 
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Please note the use of double-colon (::) and comma (,). This denotes a task with a 

start gap of 2 days and duration of 10 days.  The gap of a task is defined as the 

buffered days between its last dependency fulfillment and its start date.  The 

duration defines the length of the task in days. 

Tasks versus Containers 

If you do not specify Gap and Duration of a task, then the task will be marked as a 

Container (one that only holds documents and files for the task node, but its 

timeline will be ignored) rather than a project timeline task.  You don't need to 

make a decision at this point; you can always change it in Step 2 (Setting Project 

and Task Dates) or at any point in the life of the project. 

Publish the Newly Created Project 

When you are satisfied with the project plan, you can click the Publish button, 

which is located at the bottom of the page Review and Publish the Project Plan.  

Once published, you can access this project on the Web.  At this point, you are the 

only person in this project team and the project timeline may not be set up.  We 

will do these in the next step in Project Planning. 

  

Step 2: Project Planning 

  

Now the project is created and published, you want to complete the project planning 

before starting to run the project.  In this step, you will add members to the project team, 

assign them with the responsibilities of certain tasks, and set the planned dates of the 

tasks.  At the end of this step you will see a timeline, in a Gantt Chart, of the project. 

Add Project Team Members 

If you do not have other members of your company or organization in CPM, this 

is the time you can register them.  To do that, click on the Home Tab to go to the 

Home Page, and click New User under the submenu.  For each person you added, 

CPM would automatically send account information to him/her. 

To select and add members of your organization to the project team, on the Home 

Page click on the name of the project you have just created, or click the Project 

Tab and make sure the right project is selected.  When you are in the Project Plan 

Page, under the Project Tab, click on the submenu item Project Profile.  You will 

see the current project information, with the project team on the right-hand-side 

column.  Click the link that says Add project team member, and you will be in the 

Update Project Profile Page.  Now scroll down to the Team Members area, 

highlight the people on the left and click the Add button to add them to the project 

team.  When you are done, save your change by clicking the Submit button at the 

bottom of the Page. 
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Assign Tasks to Team Members 

Once you have added more members to the project team, you can assign them to 

be owners of different tasks.  Task owners are responsible on the task.  Using 

CPM a task owner may report the status of the task to the team.  Unlike traditional 

Project Management tool which relies on a project manager to collect status from 

team members and update the project status, CPM empowers various task owners 

to report on different aspects of the project. 

On the project plan page, click on the name of a task to go to the Task 

Management Page.  Here you can transfer ownership of a task, or a group of tasks 

in a sub-tree, to another project team member.  Task owners may further transfer 

some of their tasks to other users, as long as these users are part of the project 

team. 

Task owners will receive email notifications from CPM when their tasks are ready 

to start (e.g. all dependencies are fulfilled), or when the task deadline is 

approaching.  See Step 3 (Email Notification and Watcher) for more details. 

Setting Project Dates 

The whole project has a Start Date and an Expire Date (deadline), and between 

them each of the tasks also has Start Dates and Expire Dates.  Each of Start and 

Expire Dates are further split into three dates.  Therefore, for each task there are 

these dates: 

Original Start Date - This is set based on the project template.  The project 

owner and task owner change it to note the original plan.  Once the project 

started, only the project owner may change it. 

Planned Start Date - This is the current planned start date of the task.  This may 

change repeatedly due to the current project timeline situation.  The project owner 

or task owner may change this date. 

Actual Start Date - This is a date set by CPM either when user explicitly starts a 

task or when the task is started by CPM because all conditions are fulfilled. 

 Original Deadline - This is set based on the project template.  The project owner 

and task owner change it to note the original plan.  Once the project started, only 

the project owner may change it. 

Planned Deadline - This is the current planned deadline of the task.  This may 

change repeatedly due to the current project timeline situation.  The project owner 

or task owner may change this date. 

Actual Completion Date - This is a date set by CPM when user indicates that the 

task is completed. 

At this planning stage of the project, either project owner or task owner may use 

CPM to set the original and planned dates.  Once the project starts to run, only the 

project owner may change the original dates.  To set the planned dates, user may 

either set the planned dates explicitly, or they may set the Gap and Duration of the 

tasks. 
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Gap - The gap is the buffered days before a task is started.  For a task which has a 

dependency on other tasks, when all the dependencies are fulfilled, the task is 

ready to start.  But user may define a buffer to create some rooms before the task 

is required to start.  The Planned Start Date therefore is calculated based on the 

Planned Deadline of a task's dependent tasks and its Gap.  During the gap time, 

the task owner may explicitly start a task, so as to gain a head-start on the task 

assignment.  If not, CPM will automatically start the task on the Planned Start 

Date. 

For a task without dependency, if a Gap is defined, the Start Date will be 

calculated using the Start Date of its parent task, plus the Gap.  For a sub-task, 

say, 2.3.4, the parent is its lower level task, in this example 2.3.  For a top-level 

task, say 2, the parent is the project. 

Duration - This defines the length of the task in days.  The Planned Deadline is 

calculated based on the Planned Start Date and the Duration of a task. 

Phases or Milestones 

Sometimes it is helpful to divide a project into multiple phases.  When the team 

exits a phase, it is considered to have reached a milestone.  You can easily define 

project phases in CPM by associating a top-level task to a phase. 

Click the Project Tab and choose a project.  Click on the name of a task that you 

want to use as a phase.  In other words, all the sub-tasks under this task would be 

accounted for as tasks within this phase.  Note that a task must be a non-container 

type of task in order to be set as a Phase. 

You are now in the Task Management Page.  Check the checkbox "Set as phase", 

which is located on the right side under the Tab menu-bar.  Click the Project Tab 

to go back to the project plan; you should see Phase 1 marked on the project plan 

tree.  Repeat this process to define other phases for the project. 

Project Timeline 

Click the Project Tab to go to the Project Plan Page.  On the top right-hand corner 

click the link "Timeline".  A Gantt chart of the project should appear.  If you are 

the project owner you would be able to change the timeline of each of the tasks by 

dragging the triangular dots (in blue and red) associated to each task.  Task owner 

may only change timeline of the tasks they own. 

Note also that the critical path of the project is listed at the bottom of the timeline 

window. 
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Step 3: Project Tracking and Monitoring 

Starting a Project 

o Project options 

Before starting a project, you might want to set up some project options that 

help in tracking and monitoring the project.  On the Project Plan Page, click the 

submenu item Project Profile, then click the Update Project Profile link on the 

upper right-hand corner.  Scroll to the Project Option area.  You have several 

options to set for the project. 

- Submit project plan change by members 

- Expand project tree at start 

- Notify all team members on new postings 

- Notify owner when task fails deadline 

o Set project state to OPEN 

A project goes from NEW to OPEN to COMPLETE to CLOSE.  To start a 

project, go to the Update Project Profile Page and change the Project Status 

from NEW to OPEN, and then click the Submit Button at the bottom of the 

page. 

Starting a Task 

A task should be started when it hits the Start Date of the task according to the 

timeline.  However, if there are dependencies defined, then all tasks that this task 

depends on must be completed before this task can start. 

When a task is started (in the OPEN state), a work item will be created in 

association to the task for user to track the on-going work of the task. 

o CPM automatically starting a task 

CPM will automatically start a task if the following conditions are fulfilled: 

- All dependencies of the task are fulfilled; and 

- The Start Date of the task has arrived. 

When the task is started automatically, CPM will send a notification email to 

the task owner. 

o Set task state to OPEN 

When all the dependencies of a task has been fulfilled but the Start Date has not 

arrived yet (this is usually the case when there is a non-zero gap defined on the 



CPM Help File  6 

task), the task owner may explicitly start a task.  To do that, in the Project Plan 

Page, click the name of the task you want to start.  In the Task Management 

Page, scroll to the area of the Task Status and change it from NEW to OPEN, 

and then click the Submit Button at the bottom of the page. 

o Complete a task's work item 

When a task is OPEN, there is a work item associated to it.  You go to the 

worktray (see the Worktray and Task Management Section below) and select 

the associated work item to report on the status, progress or issues of the task. 

When the task's work has been done, you can move the task status to 

COMPLETE.  To do that, again, go to the Task Management Page and change 

the task status from OPEN to COMPLETE.  Alternatively, just for 

convenience, you may also commit the associated work item.  This would 

automatically move the task to the COMPLETE state. 

Worktray and Task Management 

The worktray is the place where the employee tracks and reviews all the work 

tasks of all projects that is waiting for him/her to perform.  Managers can use the 

worktray to monitor project progress and provide feedbacks to other team 

members. 

The worktray of an employee holds all the active work items that are waiting for 

him/her to perform.  For each open (active) task there is an associated work 

item that is placed in the task owner's worktray.  To go to the worktray, from the 

Project Plan Page click the submenu item Work In-Tray.  If there is any open task 

assigned to you, then a number of work items related to this project will be 

shown.  Click on any of them and the details of the work item and the associated 

task will be shown in the Work Item box (right beneath the work item list). 

You may add a blog to the task here to report the current status or issues of the 

task.  Alternatively, if the task has been completed, you may click the Commit 

Button to indicate the task has been completed.  Click Abort if the task has been 

cancelled. 

Updating a Task 

o Post files and blogs 

Team members can post files and blogs onto a task.  On the Project Plan Page, 

click on the task name you want to post files.  In the Task Management Page, 

scroll to the place for Add File Attachments.  Click the Browse Button to select 

a file.  Repeat the selection process for multiple files.  Click Upload Files 

Button to upload the selected files.  You may see all of the file postings on a 

project by clicking the Project Tab, then click the submenu item File 

Repository. 
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To post blog, in the Project Plan Page, scroll to the task you want to post a 

blog, click the link on the right-hand (last) column of the task line.  If there are 

already blog postings on this task, then in the Blog Page, click New Post link 

under the submenu bar to post a new blog. 

o Update the dates 

As stated in Step 2 in the section of Setting Project Dates, there are six (6) dates 

for each task that concern the schedule, namely Original Start, Original 

Deadline, Planned Start, Planned Deadline, Actual Start, Actual Completion. 

While in Step 2 of Project Planning, the most convenient way to set the tasks' 

dates is to go to the Update All Tasks Page, which can be accessed through the 

Project Plan Page by click the corresponding link in the top right-hand corner. 

You may also change the task's dates by going into the Task Management 

Page.  To do that simply go to the Project Plan Page and click on the task name. 

o Transfer ownership 

If you are the project owner or task owner, you may transfer the ownership of a 

task to a project team member.  From the Project Plan Page, click on the task 

name to go to the Task Management Page.  You may transfer the task 

ownership here. 

Email Notification and Watcher 

CPM automatically sends out Email notification to the task owner one day before 

a task reaches its deadline.  It will send another email to the task owner when the 

task has expired.  On the Project Plan Page, the task status (a color ball icon) will 

change color to indicate the corresponding status. 

Project owner may set the project option to also notify all team members when 

there are file or blog postings.  Alternatively, on the Task Management Page, the 

project or task owner may set finer option on the task level to send notification 

Email. 

Finally, any team members may watch a task on his Home Page by clicking the 

link "Watch this task on my home page", which is on the top right-hand corner of 

the Task Management Page. 
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Step 4: Project Review and Report 

Blogging and Comments 

CPM is a collaborative platform solution allowing users to exchange information 

through blogging on tasks.  See the details on Step 2 about posting blogs on a task 

and through the worktray. 

Change Project Plan 

There might be a time when you need to change the project plan, such as adding 

more tasks, deleting tasks or moving the tasks around.  Project owner can update 

the project plan.  If the project option of allowing team members to submit plan 

change is selected, then they may change the plan and CPM will send the change 

notification to the project owner for approval before publishing the change. 

To change the project plan, click on the Project Tab, then click submenu item File 

Repository.  On the top right-hand corner, click the link Update Plan.  You will go 

through a few steps to update and publish the plan.  Just follow the instructions on 

the page. 

Project Summary Review 

With CPM, you no longer have to wait for a project manager to distribute project 

reports.  Management and team members can review the project status in real-

time.  On the Project Plan Page, click the submenu item Project Summary to 

access the page. 

Status Reports 

o Executive Summary 

CPM uses the task blog to capture the status report(s).  You can select one of 

the tasks in the project plan, or create a task (container) at the end of the plan 

just to hold the executive summary report.  (See above section on Change 

Project Plan on how to change the project plan and add a task to it.)  To 

identify a task as the executive summary report, note the task ID (which is 

listed on the Task Management Page).  Then on the Project Summary Page, 

click the link Project Report located on the top right-hand corner of the page.  

Here you can enter the Executive Summary task ID and click Save. 

o Phase Reports 

For each of the tasks that is identified as a phase, the task blog will be used as 

the phase report and will show up in the Project Summary Page. 

o Report Distribution 
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The project owner may trigger to send a periodic project report to a group of 

recipients.  On the Project Summary Page, click the link Project Report located 

on the top right-hand corner of the page.  Here you may specify the frequency 

to send this auto report through Email. 

The content of the periodic report Email can be customized through EGI 

Global Services Team. 

  

Step 5: Project Closing 

Save Project Template 

CPM has a project plan template library that stores the projects plans for different 

types of projects.  Employees choose from the project template library a standard 

plan when they start their project.  This enables a user to quickly start a project by 

borrowing the expertise of other users in the organization; it also ensures high 

quality control over project management practice.  Projects of similar types may 

therefore have a consistent layout and timeline throughout a large and even 

distributive organization. 

You may save the project plan anytime in the life of the project when you are 

satisfied with the current project plan.  Click the Project Tab and then the 

submenu item File Repository.  On the top right-hand corner, click the link Save 

Plan Template and follow the instruction to indicate the type of project and give 

the template a name. 

Note that CPM automatically calculates the time required for each task by noting 

your current dates.  It will be recorded at the end of each task name line using the 

convention: 

task name :: Gap, Duration 

 

See Step 1 on Choosing a Project Template for more details. 

Completing and Closing a Project 

When the project is completed (that means it completed all its tasks and reach its 

objectives), the project owner may indicate that moving the project status to 

COMPLETE.  Click the Project Tab, and then click the submenu item Project 

Profile.  On the upper right-hand corner, click Update Project Profile.  Change the 

Status of the project to COMPLETE. 

After the project is completed, the project owner may want to CLOSE the 

project.  Note that once a project is closed, no one can further post files or blogs 

to the tasks.  A closed project is ready to be archived. 
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Project Analysis 

CPM automatically performs statistic analysis on closed projects.  Regression 

analysis is done over history on a number of projects.  It would also evaluate your 

organizations project by applying hedonic regression analysis method over similar 

project type of the same industry.  The Project Analysis features will be available 

in future releases. 

  

  

 


